DTP – Dynamique Trunking Protocol

Dans cet article nous étudierons un protocole propriétaire Cisco qui est le DTP (Dynamic Trunking Protocol). On retrouve ce protocole sur une liaison entre 2 switch de marque Cisco. Ce protocole sert à négocier de façon automatique un lien trunk appelé aussi port d’agrégation.

Une interface peut être configurée de 4 façons différentes.

Switch>enable
Switch#conf t
Switch(config)#inter fastEthernet 0/1
Switch(config-if)#switchport mode access

Cette commande force le switch à être un port d’accès, et désactive l’envoie de requête DTP sur le réseau.

Switch(config-if)#switchport mode trunk

Cette commande force le port à être un port trunk, et envoie des requêtes DTP au switch d’en face.

Switch(config-if)#switchport mode dynamic auto

Le mode dynamique et en quelque sorte un mode passif. Il attend patiemment un message du switch en face pour s’auto-configurer. Un port en mode auto deviendra uniquement un lien trunk si le port du switch en face est configuré soit en mode trunk ou en mode desirable, sinon il sera un port en mode access. Ce mode envoie également des requêtes DTP sur le réseau.

Switch(config-if)#switchport mode dynamic desirable

Le mode desirable, lui est un mode actif. C’est-à-dire qu’il envoie des requêtes DTP au switch en face pour lui faire une proposition de trunk.

Voici un tableau reprenant toutes les possibilités que nous pouvons retrouver avec la configuration du DTP entre 2 switch

Mode AUTO

Mode DESIRABLE

Mode TRUNK

Mode ACCESS

Mode AUTO

Access

Trunk

Trunk

Access

Mode DESIRABLE

Trunk

Trunk

Trunk

Access

Mode TRUNK

Trunk

Trunk

Trunk

Non fonctionnelle

Mode ACCESS

Access

Access

Non fonctionnelle

Access

Comme vous l’avez compris, de façon régulière, un switch envoie des requêtes DTP sur le réseau. Voici la commande pour annuler ces envois

Switch(config)#inter fastEthernet 0/1
Switch(config-if)#switchport nonnegociate

Pour vérifier les liaisons trunk et le protocole DTP la commande est la suivante :

Switch#sh interface trunk image

Nous pouvons voir les 3 modes configuré sur ce switch. Pour plus de détails, la maquette est disponible sur ce lien ici

Vous pouvez egalement vous rapprochez des cours officiels Cisco Netacad ici

!!!! CISCO FOREVER !!!!

Publicités

Routage inter VLAN – Switch de niveau 3 partie 2/2

Voici une toute nouvelle mission : mettre en place du routage inter VLAN.
Dans cet article nous nous appuierons sur la maquette si dessous. Le routage inter vlan se fera sur le Switch Coeur.

Pour bien comprendre ce tuto, des maquettes sont disponibles sur les liens suivants
– Maquette vierge disponible ici
– Maquette complète disponible ici

Ces maquettes sont disponibles pour packet tracer version 7.0 et plus

Cet article sera en quelque sorte la suite de celui-ci :
https://ciscotracer.wordpress.com/2014/11/05/vlan-virtual-lan-local-area-network/

clip_image002

Voici la configuration du switch SW1 qui sera identique pour SW2 et SW3.
SW1>enable
SW1#configuration terminal
SW1(config)#vlan 10
SW1(config-vlan)#name LAN_BLEU
SW1(config-vlan)#vlan 20
SW1(config-vlan)#name LAN_VERT
SW1(config-vlan)#interface fastethernet 0/2
SW1(config-if)#switchport access vlan 10
SW1(config-if)#interface fastethernet 0/3
SW1(config-if)#switchport access vlan 20
SW1(config-if)#interface fastethernet 0/1
SW1(config-if)#switchport mode trunk

Voici maintenant la configuration du switch Cœur de réseau

Création des 2 vlans
COEUR>enable
COEUR#configure terminal
COEUR(config)#vlan 10
COEUR(config-vlan)#vlan 20
COEUR(config)#interface range fastethernet 0/1-3
COEUR(config-if-range)#switchport mode trunk
Command rejected: An interface whose trunk encapsulation is « Auto » can not be configured to « trunk » mode.

Ce message est dû au protocole DTP (Dynamic trunking protocol) qui est une negociation automatique d’une liaison trunk. J’expliquerai le DTP dans un prochain article.

Dans ce message nous ne pouvons passer l’interface en mode trunk car celle-ci est configurée nativement en mode “auto”
Pour résoudre ce probleme, voici une solution. Modifier l’encapsulation ISL qui est par defaut par la dot1q
COEUR(config-if-range)#switchport trunk encapsulation dot1q
COEUR(config-if-range)#exit

Créations de interfaces vlan 10 et 20 qui servirons de passerelles pour les postes clients
COEUR(config)#interface vlan 10
COEUR(config-if)#ip address 192.168.10.254 255.255.255.0
COEUR(config-if)#interface vlan 20
COEUR(config-if)#ip address 192.168.20.254 255.255.255.0
COEUR(config-if)#exit

Par defaut un switch de niveau 3 reste de base un simple switch c’est à dire qu’il ne sais pas router. Pour faire communiquer les VLANs entre-eux, il faut activer le routage avec la commande suivante:
COEUR(config)#ip routing

A cette étape de ce tuto le routage inter-vlan fonctionne. Seul le premier ping sera perdu.
clip_image004

Pour finaliser le TP, nous devons rediriger le traffic des VLAN10 et 20 vers le WAN
Voici comment donner une adresse sur le port d’un switch
COEUR(config)#inter fa 0/4
COEUR(config-if)#no switchport
COEUR(config-if)#ip address 192.168.30.1 255.255.255.0
COEUR(config-if)#exit

Pour finaliser le routage sur le switch nous devons créer une route par défaut vers le routeur R1
COEUR(config)#ip route 0.0.0.0 0.0.0.0 fastEthernet 0/4

La dernière étape sera de configurer R1 :
Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.30.254 255.255.255.0
Router(config-if)#exit

Par défaut le routeur n’a pas connaissance des réseaux du vlan 10 et 20. Nous devons lui indiquer les réseaux à joindre via la route statique suivante
Router(config)#ip route 192.168.0.0 255.255.0.0 192.168.30.1

Vous avez à présent un accès vers le WAN et vous pouvez donc pinger 8.8.8.8

Mission accomplie !!! Cisco Forever 😀 !!!

ROUTAGE STATIQUE IPv4

Notre nouvelle mission : faire communiquer les 2 réseaux LAN avec du routage statique, avec mise en place de routes statiques de backup (appelés aussi routes flottantes) ainsi qu’une route par défaut

clip_image002

Pour télécharger la maquette vierge cliquez ici

L’adressage étant configuré nous nous attarderons uniquement sur le routage statique.

ROUTAGE STATIQUE

Il existe 3 types de route statique, les différences se jouent sur la fin de la commande
– Les routes appelées connectées (ne pas confondre avec les routes directement connectés)
(config)# ip route [réseau de destination] [masque du réseau destination][Interface de sortie]

IMPORTANT : Cette commande est à taper pour les liaisons points to points seulement. Celle-ci ne fonctionnera pas sur les liaisons multi-points

– Les routes appelées récursives
(config)# ip route [réseau de destination] [masque du réseau destination] [IP du routeur voisin]

Cette commande est à utiliser pour les liaisons multi-points. On référence l’adresse IP du routeur voisin afin d’envoyer le paquet vers la bonne destination

– Une route totalement renseigné :
(config]# ip route [réseau de destination] [masque du réseau destination] [Interface] [IP]

Note : Cette commande n’est pas disponible sous packet tracer pour l’IPv4 mais l’est pour l’IPv6

Configuration du routeur R1 avec des routes connectées :
Actuellement notre routeur connait 4 routes. Ces routes sont référencées par la lettre C comme Connected

clip_image006

L’objectif est donc de référencer l’ensemble des réseaux qu’il ne connait pas. J’ai au total 7 réseaux dans la maquette. Il me reste donc 3 réseaux à référencer. Nous allons faire en sorte que les routeurs empruntes les chemins les plus cours pour joindre la destination.

Voici les routes pour R1 :
R1>enable
R1#configure terminale
R1(config)#ip route 192.168.3.0 255.255.255.0 fastEthernet 1/1
R1(config)#ip route 192.168.4.0 255.255.255.0 fastEthernet 1/1
R1(config)#ip route 192.168.6.0 255.255.255.0 fastEthernet 1/1

On aurait pu remplacer fastEthernet 0/1 par 192.168.2.254, celle-ci serait donc une route récursive. Ce qui aurait donné :
R1(config)#ip route 192.168.3.0 255.255.255.0 192.168.7.254
R1(config)#ip route 192.168.4.0 255.255.255.0 192.168.7.254
R1(config)#ip route 192.168.6.0 255.255.255.0 192.168.7.2541

NOTE : Dans notre cas, je n’ai pas renseigné les routes récursives sur les routeurs

Nous pouvons vérifier la configuration avec la commande « show ip route »

clip_image011

Les routes Statiques sont caractérisées par la lettre S comme STATIC vous l’avez deviné.

Voici les routes pour R2
R5>enable
R5#configure terminal
R5(config)#ip route 192.168.5.0 255.255.255.0 fastEthernet 0/1
R5(config)#ip route 192.168.1.0 255.255.255.0 fastEthernet 0/1
R5(config)#ip route 192.168.4.0 255.255.255.0 fastEthernet 0/0
R5(config)#ip route 192.168.6.0 255.255.255.0 fastEthernet 0/0

Ou les routes récursives :
R5(config)#ip route 192.168.5.0 255.255.255.0 192.168.2.1
R5(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1
R5(config)#ip route 192.168.4.0 255.255.255.0 192.168.3.1
R5(config)#ip route 192.168.6.0 255.255.255.0 192.168.3.1

Note : Je ne référence pas volontairement le réseau 7.0 je n’en ai pas besoin

Voici les routes pour R3
R4>enable
R4#configure terminal
R4(config)#ip route 192.168.5.0 255.255.255.0 fastEthernet 1/0
R4(config)#ip route 192.168.1.0 255.255.255.0 fastEthernet 1/0
R4(config)#ip route 192.168.2.0 255.255.255.0 fastEthernet 1/0

Ou les routes récapitulatives
R4(config)#ip route 192.168.5.0 255.255.255.0 192.168.7.1
R4(config)#ip route 192.168.1.0 255.255.255.0 192.168.7.1
R4(config)#ip route 192.168.2.0 255.255.255.0 192.168.7.1

Si maintenant nous lançons un ping du PC6 vers PC2 nous obtenons cela :

clip_image018

Nous avons 3 Ping de perdu sur 4. Cela est dû à la requête ARP exécutée entre chaque routeur sur les liaisons Ethernets

LA ROUTE PAR DEFAUT

Lorsqu’un routeur doit pouvoir accéder à internet ou d’autre réseau qui lui sont inconnus, il faut lui référencer une route par défaut. Cette route permet de lui indiquer un chemin de dernier recours.

Configuration du routeur R1
R1(config)#ip route 0.0.0.0 0.0.0.0 fa0/1

Ou
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.254

Configuration du routeur R2
R1(config)#ip route 0.0.0.0 0.0.0.0 fa1/0

NOTE : Ne connaissant pas l’adresse du routeur en face, il n’y a pas de route récursive…

Configuration du routeur R3
R1(config)#ip route 0.0.0.0 0.0.0.0 fa0/1

Ou
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.3.254

A présent chaque PC peut pinger le serveur 8.8.8.8 dans le cloud.

clip_image023

 

NOTE : Il y aura un maximum 3 Ping de perdu. Ce nombre peut varier en raison de plusieurs facteurs. Il y a toujours cette requête ARP que les routeurs effectuent sur les liaisons Ethernets.

ROUTE DE BACKUP

L’inconvénient du routage statique est qu’il ne s’adapte pas automatiquement au changement de topologie lors d’un incident. Dans notre maquette l’incident viendra sur la liaison entre R1 et R3.

Pour cela nous allons ajouter une route de secours, qu’on appelle dans le jargon Cisco une route flottante. Il suffit juste de modifier la Distance Administrative.

Qu’est qu’une Distance Administrative (DA) :

Sur un routeur la DA est une valeur de fiabilité. Plus elle est faible plus est fiable. Par défaut, la DA d’une route statique est de 1 (donc très fiable).

Nous pouvons retrouver cette valeur dans la table de routage avec uniquement des routes récursives :
NOTE : Pour ce screenshot, j’ai volontairement remplacé une route connectée par une récursive sur R1

clip_image026

Pour la redondance nous devons ajouter une route secondaire avec une DA plus élevé. De cette façon quand la maquette est opérationnelle à 100% le routeur prendra le meilleur chemin, mais si un incident arrive sur la liaison principale, la route primaire disparait de la table de routage pour laisser la place à la route secondaire.

Router R1
Pour joindre les réseaux 192.168.3.0, 192.168.4.0 et 192.168.6.0 le chemin de secours est de passer par R2

Voici donc les routes récursives :
R1(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.254 5
R1(config)#ip route 192.168.4.0 255.255.255.0 192.168.2.254 5
R1(config)#ip route 192.168.6.0 255.255.255.0 192.168.2.254 5

La route par défaut empruntera l’autre chemin
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.7.254 5

Router R3
Pour joindre les réseaux 192.168.2.0, 192.168.5.0 et 192.168.1.0 le chemin de secours est de passer par R2

Voici donc les routes récursives :
R3(config)#ip route 192.168.2.0 255.255.255.0 192.168.3.254 5
R3(config)#ip route 192.168.5.0 255.255.255.0 192.168.3.254 5
R3(config)#ip route 192.168.1.0 255.255.255.0 192.168.3.254 5

La route par défaut empruntera l’autre chemin
R3(config)#ip route 0.0.0.0 0.0.0.0 192.168.7.1 5

Router R2
Pour joindre les réseaux 192.168.5.0 et 192.168.1.0 le chemin de secours est de passer par R3

Voici donc les routes récursives :
R2(config)#ip route 192.168.1.0 255.255.255.0 192.168.3.1 5
R2(config)#ip route 192.168.5.0 255.255.255.0 192.168.3.1 5

Pour joindre les réseaux 192.168.4.0 et 192.168.6.0 le chemin de secours est de passer par R1

Voici donc les routes récursives :
R2(config)#ip route 192.168.4.0 255.255.255.0 192.168.2.1 5
R2(config)#ip route 192.168.6.0 255.255.255.0 192.168.2.1 5

Pour vérifier, coupons la liaison en R1 et R3 et faisons un show ip route sur R2

clip_image032

Nous voyons bien les routes avec les DA à 5 qui ont pris le relais.

Faisons un test de ping de PC1 vers PC5.

clip_image034

Avec 3 pings de perdu dû au changement de route et aux requêtes ARP, le test est opérationnel.

N’hésitez pas à faire des pings en continu et de tester en temps réel les coupures sur une seule liaison à la fois, vous verrez que le changement de route est assez rapide tout de même.

Vous trouverez ici la maquette réalisé.

Moi je dis Mission accomplie.

Cisco Forever !!!

Etherchannel (LACP – PAGP)

Voici une toute nouvelle mission : Configuration de liens agrégés dans une topologie LAN.
clip_image002

Un peu de théorie :
A ma connaissance il existe 2 protocoles d’agrégation de lien qui sont PAgP et LACP. L’objectif de cette agrégation est d’augmenter la bande passante en fusionnant plusieurs liens physiques par un seul lien logique.
Cette techno utilise la norme IEEE 802.1AX
Si j’utilise 3 liens de 100Mbit/s pour en faire un lien logique, le débit sera de 300Mbit/s
Dans le jargon Cisco, on parle également d’Etherchannel quand nous utilisons une agrégation de liens.
Une agrégation peut compter au maximum 8 interfaces physiques

PAgP (Port Aggration Protocol)
PAgP est un protocole propriétaire Cisco. Ce protocole utilise 3 statuts dans sa configuration :
On : sert à déclarer une agrégation active
Désirable : C’est un mode qui fait la demande avec le switch d’en face pour créer l’agrégation
Auto : C’est un mode qui attend la négociation pour devenir une agrégation.

Voici les modes de compatibilité avec PAgP

On Desirable Auto
On Compatible Non Compatible Non Compatible
Désirable Non Compatible Compatible Compatible
Auto Non Compatble Compatible Non Compatble

LACP (Link Aggregation Control Protocol)
LACP est un protocole standard pouvant communiquer avec différents constructeurs.
Ce protocole utilise également 3 statuts dans sa configuration :
On : Sert à déclarer une agrégation active
Active : C’est un mode qui fait la demande avec le switch d’en face pour créer l’agrégation
Passive : C’est un mode qui attend la négociation pour devenir une agrégation

Voici les modes de compatibilité avec LACP

On Active Passive
On Compatible Non Compatble Non Compatble
Active Non Compatble Compatible Compatible
Passive Non Compatble Compatible Non Compatble

Configuration Swich SW1
SW1>enable
SW1#configure terminal
SW1(config)#interface range fa0/1-3
SW1(config-if-range)#channel-group 1 mode desirable
!
SW1(config-if-range)#interface range fa0/7-9
SW1(config-if-range)#channel-group 2 mode desirable

Configuration Swich SW2
SW2>enable
SW2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
SW2(config)#interface range fa0/1-3
SW2(config-if-range)#channel-group 1 mode auto
!
interface range fa0/4-6
SW2(config-if-range)#channel-group 3 mode desirable

Configuration du Switch SW3
SW3>enable
SW3#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
SW3(config)#interface range fa 0/4-6
SW3(config-if-range)#channel-group 3 mode auto
!
SW3(config)#interface range fa 0/7-9
SW3(config-if-range)#channel-group 2 mode auto

Suite à la configuration vous deviez avoir une topologie qui ressemble à cela.
clip_image004

Pour vérifier votre configuration d’agrégation faites comme suit:
SW1#show etherchannel summary

clip_image006

Dans la colonne Port-channel vous voyez vos interfaces agrégées logiques avec les ports physiques attribués à ce port.

Pour configurer le port agrégé faites comme suit :
SW1(config)#interface port-channel 1

Vous être à présent sur l’interface agrégée du groupe N°1.
Vous pouvez donc passer l’interface en mode trunk, lui attribué une sécurité avec port-sécurity ou un bpduguard, etc …

Il existe une méthode de load balancing avec ce protocole mais cela fera l’objet d’un prochain article.

!!! Cisco Forever !!!

VOIP avancé – Interconnecter 2 Call Manager Express (CME)

 

Une nouvelle mission ? Faire communiquer 2 Call Manager ça vous tente ?

Voici notre maquette.
clip_image002

L’idée ici n’est pas de configurer le routage des 2 sites mais juste d’interconnecter Les 2 Call Manager Express (CME1 et CME2)
Pour une configuration de base d’un call manager redirigez-vous sur cette article :
https://ciscotracer.wordpress.com/2015/02/26/configuration-dun-call-manager-express/

Pour commencer voici la configuration de base pour notre CME1

telephony-service
max-ephones 42
max-dn 144
ip source-address 192.168.2.253 port 2000
auto assign 1 to 144
!
ephone-dn 1
number 2001
!
ephone-dn 2
number 2002
!
ephone 1
device-security-mode none
mac-address 0050.0FCC.D225
type 7960
button 1:1
!
ephone 2
device-security-mode none
mac-address 000C.857C.CB66
type 7960
button 1:2

Voici à présent la configuration du CME2

telephony-service
max-ephones 42
max-dn 144
ip source-address 192.168.1.253 port 2000
auto assign 1 to 144
!
ephone-dn 1
number 1001
!
ephone-dn 2
number 1002
!
ephone 1
device-security-mode none
mac-address 0002.16E2.5C47
type 7960
button 1:1
!
ephone 2
device-security-mode none
mac-address 0001.C7C2.ED51
type 7960
button 1:2

A présent, configurons la passerelle du CME1 pour joindre le CME2

CME1(config)#dial-peer voice 1 voip

! Création de la passerelle que nous appelons « 1 »

CME1(config-dial-peer)#destination-pattern 1…

! identification des numéros à 4 chiffres commençant par 1

CME1(config-dial-peer)#session target ipv4:192.168.1.253

! identification de l’IP du CME distant gérant les numéros commençant par 1

Et voici la configuration du CME2 pour joindre CME1. Seul les numéros et l’IP du Call Manager changent.

CME2(config)#dial-peer voice 2 voip
CME2(config-dial-peer)#destination-pattern 2…
CME2(config-dial-peer)#session target ipv4:192.168.2.253

Les téléphones de sites distants peuvent dès à présent s’appeler.

!!! Cisco Forever !!!

Nat dynamique IPv6 to IPv4 – NAT PT

Notre nouvelle mission: être capable de natter de l’IPv6 vers de l’IPv4.
Voici donc notre maquette:
clip_image002

Je vous laisse configurer votre PC0 comme suit :
clip_image004

Toute la configuration qui suivra se fera sur le routeur0
Pour commencer nous allons configurer les l’IPs sur l’interface fa0/0 et fa0/1

router0>enable
router0#configure terminal
router0(config)#interface FastEthernet0/0
router0(config-if)#ipv6 address 2001:1::1/64
router0(config-if)#no shutdown
router0(config)#interface FastEthernet0/1
router0(config-if)#ip address 192.168.0.1 255.255.255.0
router0(config-if)#no shutdown

Votre PC doit pinger l’adresse IPv6 du routeur
clip_image006

Passons à la configuration du NAT
Tout d’abord nous devons identifier les interfaces qui utiliseront le NAT

router0>enable
router0#configure terminal
router0(config)#interface FastEthernet0/0
router0(config-if)#ipv6 nat
router0(config)#interface FastEthernet0/1
router0(config-if)#ipv6 nat

Il faut savoir qu’un hôte IPv6 n’accèdera jamais à une IPv4. C’est pourquoi nous devons simuler au PC0 que l’IPv4 est une IPv6 grâce à un préfixe. Dans cette maquette nous configurerons le préfix par 2002::/96
96 = 128 – 32
Exemple : pour joindre l’IPv4 8.8.8.8 nous dirons au PC0 de joindre l’IP 2002::8.8.8.8
Ainsi l’hôte pense que 8.8.8.8 est une IPv6 en 2002::8.8.8.8

Configurons le réseau LAN avec une permission pouvant accéder au préfix 2002::/96 par une ACL
!–configuration du préfix
Router(config)#ipv6 nat prefix 2002::/96
!–configuration de l’ACL
Router(config)#ipv6 access-list v4map_acl
Router(config-ipv6-acl)# permit ipv6 2001:1::/64 2002::/96
!–attribution de l’ACL au Préfix
Router(config)#interface fastEthernet 0/0
Router(config-if)#ipv6 nat prefix 2002::/96 v4-mapped v4map_acl

Nous allons à présent donner l’autorisation de natter les IPv6 vers l’IPv4 ayant le prefix 2002::/96
!–configuration de l’ACL
Router(config)#ipv6 access-list listipv4
Router(config-ipv6-acl)# permit ipv6 2001:1::/64 2002::/96>
! configuration du NAT v6 vers v4
ipv6 nat v6v4 source list listipv4 interface FastEthernet0/1 overload

Enfin, nous terminerons par activer le routage IPv6
Router(config)#ipv6 unicast-routing
Puis une route IPv4 par defaut
Router(config)#ip route 0.0.0.0 0.0.0.0 FastEthernet0/1

Je peux à présent pinger une IPv4 grâce à mon préfix 2002 ::/96
clip_image008

Cisco Forever 😀 !!!

Pour du tunneling IPv6 via IPv4 voici le lien: ;-P
https://ciscotracer.wordpress.com/2014/07/29/ipv6-tunneling-ipv6ip/

Routage inter VLAN (partie 1/2) – Router On a Stick

Voici une toute nouvelle mission : mettre en place du routage inter VLAN.

Dans cet article nous nous appuierons sur la maquette ci dessous. Le routage inter vlan se fera sur le routeur R1.

clip_image002

Cet article sera en quelque sorte la suite de celui-ci :
https://ciscotracer.wordpress.com/2014/11/05/vlan-virtual-lan-local-area-network/

Voici la configuration du switch SW1 qui sera identique pour SW2 et SW3.
SW1>enable
SW1#configuration terminal
SW1(config)#vlan 10
SW1(config-vlan)#name LAN_BLEU
SW1(config-vlan)#vlan 20
SW1(config-vlan)#name LAN_VERT
SW1(config-vlan)#interface fastethernet 0/2
SW1(config-if)#switchport access vlan 10
SW1(config-if)#interface fastethernet 0/3
SW1(config-if)#switchport access vlan 20
SW1(config-if)#interface fastethernet 0/1
SW1(config-if)#switchport mode trunk

Voici maintenant la configuration du switch SW4
Switch>enable
Switch#configure terminal
SW1(config)#vlan 10
SW1(config-vlan#name LAN_BLEU
SW1(config-vlan#vlan 20
SW1(config-vlan#name LAN_VERT
Switch(config#interface range fastEthernet 0/1-4
Switch(config-if-range)#switchport mode trunk

Passons à présent à la partie principale : « La configuration du router. »

Nous activons tout d’abord l’interface physique fa0/0
Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#no shutdown

Nous allons créer une interface virtuelle pour le VLAN 10
Router(config-if)#interface fastEthernet 0/0.1

Nous modifions l’encapsulation en dot1Q et nous la taguons sur le VLAN 10
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 192.168.10.254 255.255.255.0

Nous faisons la même commande pour le vlan 20
Router(config-subif)#interface fastEthernet 0/0.2
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.20.254 255.255.255.0

Nous pouvons afficher la configuration des interfaces avec la commande :
Router# show ip interface brief

clip_image004

Configurons à présent l’adresse IP d’un PC du vlan 10
clip_image006

Configurons à présent l’adresse IP d’un PC du VLAN 20
clip_image008

La default gateway représente l’adresse IP configurée sur l’interface virtuelle du routeur. C’est notre passerelle pour sortir vers d’autres réseaux.
Dans notre maquette :
Les PCs dans le VLAN 10 auront une IP et une gateway en 192.168.10.X
Les PCs dans le VLAN 20 auront une IP et une gateway en 192.168.20.X

Sur un PC du vlan 10 nous allons pinger un PC du vlan 20
clip_image010

Si vous vous posez la question :
« Pourquoi le premier ping de passe pas ? »

Je vous repondrai :
« C’est à cause de la requête ARP créé juste avant le paquet ICMP (protocole ping) »

« Mais c’est quoi une requête ARP ? »
Avant un prochain article sur ce sujet, je vous propose de relire votre cours dans le CCNA1 au chapitre 5 partie 2
Lorsque l’article sera édité, je mettrai le lien en remplacement de cette phrase 😉

Si maintenant vous désirez ajouter un serveur DHCP pour vos VLANs voici un article pour vous.
https://ciscotracer.wordpress.com/2013/11/26/pourquoi-mes-requtes-dhcp-ne-traversent-pas-le-routeur-2/

!!! Cisco Forever 😀 !!!