routage

Routage Dynamique IPv4 avec OSPF

Notre nouvelle mission : faire communiquer l’ensemble des réseaux avec OSPF et configurer une connexion vers le réseau WAN

image

Pour télécharger la maquette vierge cliquez ici
Pour télécharger la maquette complète cliquez ici

L’adressage étant configuré nous nous attarderons uniquement sur le routage dynamique.

ROUTAGE DYNMAIQUE
OSPF est un protocole dans la catégorie IGP (Interior Gateway Protocol) c’est-à-dire un protocole utilisé au sein d’une entreprise tel un FAI par exemple. Son algorithme SPF de « Dijkstra » permet de choisir le chemin le plus adapté en fonction de la vitesse du lien. Il va cumuler l’ensemble des liaisons pour atteindre une destination et en définir un certain coût

Configuration du router0 :
Actuellement sur notre router0, en faisant un « show ip route » nous n’avons que les routes auquel notre routeur est directement connecté.

Router0#sh ip route

image

Pour configurer OSPF sur le router tapez les commandes suivantes :

Router0>enable
Router0#configure terminale
Router0(config)#router ospf 1

Le numéro 1 représente l’ID ospf pour ce routeur.
Il n’est pas obligé d’être identique sur chaque routeur de la topologie.

Router0(config-router)#router-id 1.1.1.1

l’ID se présente sous le forme d’une IP. Celle-ci n’a pas d’impact conséquent dans notre topologie. Il sert uniquement à informer les routeurs voisins qui il est.
Cette IP n’est pour autant dans la table de routage des routeurs. C’est un peu la carte d’identité du routeur dans la zone OSPF 1

Router0(config-router)#network 192.168.3.0 0.0.0.255 area 0
Router0(config-router)#network 192.168.4.0 0.0.0.255 area 0
Router0(config-router)#network 192.168.5.0 0.0.0.255 area 0

Dans cette partie, nous renseignons les réseaux auquel notre routeur0 est connecté.
Nous ne renseignons pas volontairement le réseau WAN en 209.50.144.0/30

A ce stage, notre routeur envoie des mises à jour OSPF sans recevoir de réponse. Donc notre table de routage reste encore vide puisque les routeurs voisins ne sont pas encore configurés avec le protocole OSPF.

Configuration du router1 :

Router1>enable
Router1#configure terminale
Router1(config)#router ospf 1
Router1(config-router)#router-id 2.2.2.2
Router1(config-router)#network 192.168.1.0 0.0.0.255 area 0
Router1(config-router)#network 192.168.4.0 0.0.0.255 area 0
Router1(config-router)#network 192.168.6.0 0.0.0.255 area 0

A ce stade, votre routeur1 reçoit des informations de router0 avec l’ID 1.1.1.1 pour établir une contigüité et partage ses informations de routage.

image

Voici les routes pour Router2 :

Router0>enable
Router0#configure terminale
Router0(config)#router ospf 1
Router0(config-router)#router-id 3.3.3.3
Router0(config-router)#network 192.168.2.0 0.0.0.255 area 0
Router0(config-router)#network 192.168.5.0 0.0.0.255 area 0
Router0(config-router)#network 192.168.6.0 0.0.0.255 area 0

A ce stade l’ensemble des routeurs convergent (c’est-à-dire qu’ils se mettent à jours les uns les autres), vous le voyez avec le message suivant

image

Test et vérification de la maquette

Sur routeur2, vous pouvez à présent tapez la commande « sh ip route » pour afficher la table de routage

Router2(config#)sh ip route

image

Nous voyons une nouvelle lettre « O » comme OSPF apparaitre pour identifier les routes apprises avec OSPF. Les informations de routage sont bien transmises. Pour tester la connectivité. Fais un « tracert » entre PC2 et PC1

image

La communication est opérationnelle.
L’étoile de la 3e ligne indique qu’un paquet est perdu. Cela est dû à une requête ARP effectué par Routeur0 pour demander l’adresse MAC de 192.168.3.1. C’est un processus normal, le routeur rempli progressivement sa table ARP.

La route par défaut

L’objectif est de configurer router0 avec une route par défaut vers le WAN et de diffuser celle-ci sur routeurs1 et router2 via OSPF

Configurez Router0 avec la route par defaut

Router0(config)#ip route 0.0.0.0 0.0.0.0 serial 1/2

Puis diffusez la dans OSPF

Router(config)#router ospf 1
Router(config-router)#default-information originate

Vous pouvez vérifier la propagation de cette route sur router1 ou/et router2

Router1#show ip route

image

Nous pouvons vérifier que la route se propage bien avec l’indice O*E2.

Test de la maquette

Pour finalisez le TP, nous vérifierons un test de connexion avec le PC0 avec un ping vers 8.8.8.8

image

Sourire MISSION ACCOMPLIE Sourire

*** CISCO FOREVER ***

 

Publicités

Routage inter VLAN (partie 1/2) – Router On a Stick

Voici une toute nouvelle mission : mettre en place du routage inter VLAN.

Dans cet article nous nous appuierons sur la maquette ci dessous. Le routage inter vlan se fera sur le routeur R1.

clip_image002

Cet article sera en quelque sorte la suite de celui-ci :
https://ciscotracer.wordpress.com/2014/11/05/vlan-virtual-lan-local-area-network/

Voici la configuration du switch SW1 qui sera identique pour SW2 et SW3.
SW1>enable
SW1#configuration terminal
SW1(config)#vlan 10
SW1(config-vlan)#name LAN_BLEU
SW1(config-vlan)#vlan 20
SW1(config-vlan)#name LAN_VERT
SW1(config-vlan)#interface fastethernet 0/2
SW1(config-if)#switchport access vlan 10
SW1(config-if)#interface fastethernet 0/3
SW1(config-if)#switchport access vlan 20
SW1(config-if)#interface fastethernet 0/1
SW1(config-if)#switchport mode trunk

Voici maintenant la configuration du switch SW4
Switch>enable
Switch#configure terminal
SW1(config)#vlan 10
SW1(config-vlan#name LAN_BLEU
SW1(config-vlan#vlan 20
SW1(config-vlan#name LAN_VERT
Switch(config#interface range fastEthernet 0/1-4
Switch(config-if-range)#switchport mode trunk

Passons à présent à la partie principale : « La configuration du router. »

Nous activons tout d’abord l’interface physique fa0/0
Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#no shutdown

Nous allons créer une interface virtuelle pour le VLAN 10
Router(config-if)#interface fastEthernet 0/0.1

Nous modifions l’encapsulation en dot1Q et nous la taguons sur le VLAN 10
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 192.168.10.254 255.255.255.0

Nous faisons la même commande pour le vlan 20
Router(config-subif)#interface fastEthernet 0/0.2
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.20.254 255.255.255.0

Nous pouvons afficher la configuration des interfaces avec la commande :
Router# show ip interface brief

clip_image004

Configurons à présent l’adresse IP d’un PC du vlan 10
clip_image006

Configurons à présent l’adresse IP d’un PC du VLAN 20
clip_image008

La default gateway représente l’adresse IP configurée sur l’interface virtuelle du routeur. C’est notre passerelle pour sortir vers d’autres réseaux.
Dans notre maquette :
Les PCs dans le VLAN 10 auront une IP et une gateway en 192.168.10.X
Les PCs dans le VLAN 20 auront une IP et une gateway en 192.168.20.X

Sur un PC du vlan 10 nous allons pinger un PC du vlan 20
clip_image010

Si vous vous posez la question :
« Pourquoi le premier ping de passe pas ? »

Je vous repondrai :
« C’est à cause de la requête ARP créé juste avant le paquet ICMP (protocole ping) »

« Mais c’est quoi une requête ARP ? »
Avant un prochain article sur ce sujet, je vous propose de relire votre cours dans le CCNA1 au chapitre 5 partie 2
Lorsque l’article sera édité, je mettrai le lien en remplacement de cette phrase 😉

Si maintenant vous désirez ajouter un serveur DHCP pour vos VLANs voici un article pour vous.
https://ciscotracer.wordpress.com/2013/11/26/pourquoi-mes-requtes-dhcp-ne-traversent-pas-le-routeur-2/

!!! Cisco Forever 😀 !!!